Intereting Posts

Ruby version> = X несовместимо с текущей версией

У меня есть rbenv, установленный в моей системе, и теперь я пытаюсь запустить стандартную команду bundle install в моем rubyовом приложении. Я получаю следующую ошибку:

activesupport-5.0.1 requires ruby version >= 2.2.2, which is incompatible with the current version, ruby 1.9.3p484

Я проверил все на своем конце и не знаю, где он получает старую версию ruby 1.9.3... так как у меня установлен 2.3.0 :

 > rbenv versions system * 2.3.0 (set by /neo-main/.ruby-version) > ruby --version ruby 2.3.0p0 (2015-12-25 revision 53290) [i686-linux] > echo $PATH /root/.rbenv/shims:/root/.rbenv/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games 

Я перезагрузился, чтобы убедиться, что в памяти ничего не было, или что-то еще.

Проверьте, откуда идет ваша команда bundle ; это, вероятно, вне rbenv. eval "$(rbenv init -)" gem install bundler а затем повторно запустите eval "$(rbenv init -)" чтобы забрать новую прокладку.